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Change history

e 8" march 2007: Corrected the LOD section, added information
regarding collision and LOS meshes and modified the 'Registering any
LOD meshes' section to include collision and LOS mesh info.

Introduction

The following guide will show you how to export a skinned model from Maya
to Torque. This applies to any model that uses joints to animate, including
characters and weapons and any static shape that needs to animate. The
tutorial will assume that the reader is familiar with modelling and texturing in
Maya and so won’t go into detail on those topics. The tutorial also assumes
that the maya2dts plug-in and DTS Utility have been installed. For information
on downloading and installing the plug-in, please go to:
http://dannyn1.web.aplus.net/torque/maya2dts/tutorials/index.htm.

The screenshots in the guide were taken using Maya 7, but should apply to
most Maya versions.
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The basic steps

Creating a character for Torque involves an 18-step process:
1. Set up Maya’s workspace to work with Torque

Create you character model

Triangulate your model

Freeze transformations on all geometry

Delete model history

UV mapping the model

Create LOD meshes (optional)

Naming the model parts for LOD identification

. Rigging and skinning your model

10. Adding special nodes

11.Adding collision meshes and LOS meshes

12.Embedding your model in the Torque hierarchy

13.Registering any LOD meshes

14. Modifying the hierarchy

15. Creating a bounding box

16. Animating the model

17.Creating a configuration file

18. Exporting the model
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Set up Maya’s workspace to work with Torque

The first step needed before creating your model is to set up Maya's
workspace so that its units and axis match those used by Torque. To do so,
load up the DTS Ultility, then in the DTS Utility menu select Setup>Set All
Units

)
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You will see Maya’s grid resize and the axis change orientation.

Create your character model

You are now ready to create your character's geometry. Note: When
modelling your character, ensure that it follows the Torque axis system i.e.: Z
axis is up, Y axis is forward and X axis is right. If your character appears
oriented incorrectly in game, the model will most likely be incorrectly oriented
in Maya.



Exporting skinned models and animations from Maya to Torque
By Amr Bekhit

Triangulate your model

All models used by Torque have to be triangulated. To do that, select all your
geometry, then in the menu select Polygons > Triangulate
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Freeze transformations an all geometry
Select all your geometry, then select Modify >Freeze Transformations >Box
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In the dialog box that appears, select Edit->Reset Settings to freeze
transformations on you geometry’s position, rotation and scale information,
then click on Freeze Transform.
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Delete model history

This step is important as it gets rid of a lot of unnecessary information which
would otherwise be exported and could cause problems.

Select your geometry then select Edit->Delete by Type >History
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UV mapping the model

With the main model geometry complete, now is a good time to UV map the
model.

Create LOD meshes (optional)

LOD meshes are low poly versions of the main model that Torque displays
instead of the main model when the model is far away from the camera. A
simple way to create LOD geometry is to select your main model, duplicate it
in the same position, then select Polygons >Reduce.
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(Note: The above image shows only the reduced model — the main model has
been hidden to take a screenshot)

After creating all the LOD meshes you need, don'’t forget to triangulate, freeze
transformations and delete history. If you have already UV mapped your main
model, then you will not need to UV map the LOD meshes.
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Naming the model parts for LOD identification

Note: in previous versions of this guide, the LOD section was incorrectly
written and the images in the guide reflected this incorrect information. The
corrections have been made in this section, but the images have not been
updated.

In order to tell the exporter the order in which we want out LOD meshes to be
displayed in the game, we add a number to the end of the name of each
mesh. The number indicates the minimum size of the object, in pixels on the
screen, that this LOD will be drawn.

For example, let's say we have 3 LOD in our model and have called them
mesh300, mesh150 and mesh0. Mesh300 will be drawn when the object is
300 pixels or greater. Mesh150 will be drawn when the object is between 150
and 300 pixels in size. MeshO will be drawn when the object is less than 150
pixels in size.

It is important to note that if we did not have meshO, then the object would not
be drawn at all when it was smaller than 150 pixels in size.

If you have just 1 mesh and no LOD, you still need to add a number to the
names of the parts and this number should be 0, so that your object is drawn
all the time.

Rigging and skinning your model

Now that the model geometry is complete, you are ready to rig and skin the
model.
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Torque supports Smooth Binding. When binding the skeleton to the mesh,
don’t forget to bind it to the LOD meshes too.

Adding special nodes

The next step involves adding Torque-specific nodes: eye and cam nodes and
mount points. To add these, open the DTS Utility and select DTS > Ultility
Nodes then select the required node.
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Place the nodes in their required positions and orient them correctly. Take
note of the nodes’ axis: in Torque, z is up, y is forward and x is right.

<\

A

After creating and placing your nodes, you may need to parent some of the
nodes to joints on your skeleton (e.g.: a mount point to a hand) so that they
move with the skeleton. To do this select the joint you want to parent to first,
then select the utility node and select Constrain>Parent>Box from the
animation menu
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In the dialog box that appears, select Edit->Reset Settings, and then click on
Add
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Repeat this for all utility nodes that need to be parented.

Adding collision meshes and LOS meshes

Note: this section does not apply to player objects, as their collision meshes
are generated in script.

In order for your model to collide with the game world, you need to add
collision meshes to the model. However, if you want your object to respond to
ray cast tests (and as a result of that, projectile collisions), then you will also
need to add LOS meshes to your model.

Both these types of collision meshes need to be convex shapes. Also, it is
recommended that these meshes be as simple as possible, since collision
detection is an intensive process.

A model can have up to 9 collision meshes, named Col 1 to Col 9, and 7
LOS meshes, called LOScol_9 to LOScol_15.

After adding collision and LOS meshes, triangulate them.

Embedding the model in the Torque hierarchy

Load up the DTS Ultility, select all your meshes (including LODs, collision and
LOS meshes, but not the skeleton) then click on the Embed Shape button.
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This creates a hierarchy which is used by the DTS format and places your
geometry in it.

Registering any LOD meshes
With your geometry still selected, click on Register Details.
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The exporter will examine the meshes in your model and create detail
markers for each LOD it identifies, named detailX, where X is the detail level.

If you have any collision or LOS meshes, then the exporter will also create
detail markers in your hierarchy corresponding to the numbers at the end of
the collision and LOS mesh names. These must be renamed to Collision_X
for collision meshes and LOS X for LOS meshes, where X is the number of
the mesh the marker represents.

Modifying the hierarchy

Open up your Hypergraph (Window->Hypergraph) or Outliner (Window->
Outliner) window (whichever you prefer working with)

m@ Animate Deform  Skeleton  Skir

} General Editors

I Rendering Editors

= Animation Editars
Relationship Editors
Settings/Preferences

r rororow
=

Attribute Editor...
Qutliner...
= | Hypergraph...

I'=

Paint Effects. ..

At this stage, your Hypergraph should look similar to this one:
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The Outliner would look like this:
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This hierarchy needs to be modified before we can export the model. We are
going to remove the geometry from the start01 node and place it at the scene
root, and then we are going to put the skeleton in its place.

Firstly, select all the geometry under start01 in the Hypergraph/Outliner, then
drag it all to the scene root using your middle mouse button. Next, select your
skeleton and drag it onto the start01 node using your middle mouse button.
Your Hypergraph should now look similar to the following:
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r—
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The Outliner would look like this:
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Note that IK handles are not moved into the start01 node.

Creating a bounding box

The next step is to create a bounding box. To do this, open the DTS Utility,
select all your character geometry and click on Create Bounding Box

{1 DTS Utility X
DTS Setup Help

Export Control

Export...

Export Shape

Euport Sequence

Ewport Settings. .

Sequence Nodes

Sequence Attributes

Create Sequence Mode

Scene Nodes
Embed Shape

Renurnber S electian...

Regizter Detailz

Bounding Box
Cieate Boundng Box |
[ Lock [ b‘I‘i{iu:le

This creates a bounding box around your character model. Tick the Lock
checkbox so that the bounding box does not occlude your model. Resize the
bounding box so that it encompasses all the model geometry at all stages of
its animation. You may need to do this after you animate your model.

Animating the model

Animation in Torque can be done in two ways. The first is where the model
and animation data are both stored in a single DTS file. The second method is
where the model is stored in the DTS file and each animation is stored in a
separate DSQ file.

-Model and animation data in single DTS file

This section assumes that you have already created the animations for your
model.

To export animations, you need to create what is called a sequence node.
You then modify the properties of the sequence node to correspond to the
animation it is supposed to represent.

To create a sequence node, open the DTS Utility and click on Create
Sequence Node
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This will create a sequence node at the centre of the scene.

Now select the sequence node then open up the Channel Editor
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The properties for the selected sequence node are displayed
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Sequence_animl
Start Frame 1
End Frame 15
Cyclic on
Blend off
end Reference Frame 0
Owerride Duration -1
Frame Rate 30
Ground Frame Rate 10
Friority 0
|gnore Ground  off
Enable Marph  off
Enable TWert off
Enable Wiz off
Enable Tranzform on
Enable Scale off
Enable Uniform Scale off
Enable Aligned Scale off
Enable Arbitrary Scale off
Enable IFL off
Force Morph off
Force TWert off
Force Wiz off
Force Transform  off
Faorce Scale off
Mum Triggers 0

By default, the DTS Utility gives sequence nodes a name of
Sequence_animX, where X is a number. To change the name of the
sequence node, replace the animX section with the name you require, for
example Sequence_wave would create an animation called wave in Torque.
Note that the Sequence prefix must be present in the node name.

The properties of the sequence node need to be modified to match the
animation it represents. For example, if a character has a wave animation that
is present in frames 10-45 in the Maya scene, you would modify the attributes
of the sequence node so that its Start Frame is 10 and its End Frame is 45.
Other properties can be modified too, for example if Cyclic is on, then the
animation will repeat indefinitely, otherwise it will play once and stop.

For each animation in your model file, place one sequence node for that
animation, name it properly and change its properties to match that particular
animation.

The model is now ready to be exported.

-Model and animation in separate DTS and DSQ files

If you want to export your animations as separate DSQ files, you need to save
each animation as a separate Maya file. Then in each file create one
sequence node, name it and modify its properties to match that animation (as
described in the above section), and then export the DSQ.

For example, to export the wave animation of a character as a DSQ file, you

would first save a copy of the main model file. In the new model file, create
the wave animation. Then create a sequence node and name it
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Sequence_wave and modify its properties to match the wave animation. The
wave animation is now ready to be exported as a DSQ file.

Repeat the above steps for each animation.

Creating a configuration file

The last step before exporting a model is to create a configuration file. In the
configuration file, list all the utility nodes (eye, cam, mount) and all the joints
that are present in the model so that the exporter will export them.

The configuration file’s name must be in the form mayafilename.cfg. For
example, if a character model is stored in the Maya file boxman.mb, its
corresponding configuration file would be called boxman.cfg.

The contents of a configuration file should look similar to this:

AlwaysExport: The file should start with this.
Eye List all the utility nodes and joints
Cam that you want to export.
mountO

mountl

root

spinel

spine?2

spine3

right hip

right knee

right ankle

left hip

left knee

left ankle

head

right shoulder

right elbow

right hand

left shoulder

left elbow

left hand

-Param: :CollapseTransforms The file should end with this.

The configuration file needs to be written using a text editor capable of saving
the file with UNIX line endings. Once such editor is SuperEdi, a free text
editor, which can be downloaded from http://www.wolosoft.com/en/superedi.
The following screenshot shows how to save the configuration file with UNIX
line endings in SuperEdi:
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Save As @@
Savein | L3 projects vl @ F M-
Y I mayaswatches i boeman, mb ] T-Eeam Cannan.mb E
i i} | def ault i boeman _anim.mb i) tester.mb
Iy Recent |2 Helmut @ﬂ boxman_root.mb @ﬂ workspace, mel
Documents ) MayaBasics i helmutz.mb l:'j boxman.cfg
= |2) Torgue Objects @ﬂhelmut model. mb l:'j boxman_root.cfg
L% |2 Torgue Test @ﬂHelmut.mb l:'j helmut.cfg
Deskiop ,j helmet. bmp @ﬂHelmut_rootZ.mb l:'j rifle. cfg
[*4 helmut..bmp i Helmut_root, mb blockrman, mtl
2 dump.dmp il Helmut_run.mb T-Bearn Cannon, mtl

My Diocuments

boxman_root.dsg
boemnan, dks

@ﬂ helmut_sword_slash.mb

@ﬂ helmut_working.mb

] boxman. abj
] T-Beam Cannon.abj

Helmut2, dts il Hoplite's Helmet.mb ] Rifle.kga
N Helrmut, dts i rifle.mb %] Hoplite's Helmet prg
- _'.g Hoplite's Helmet, dks @ﬂshield.mb ,ﬂ Rifle.png
- Rifle. dts @ﬂsword.mb m OpentayaErrorLog.bxt
by Compuiter
< >
=
hy Metwork Save az type: All Files [*.%] w
Places
Encoding: default (AMST) v %
Line endings: NI w

Once the file has been written, save the file in the same directory as your
model file.

Note: If you are exporting your model as separate DTS and DSQ files, then
only the main model scene needs a configuration file. However, if you find that
animations are not exporting correctly then create a configuration file for each
of the animation scene files. The configuration file for these is identical to the
one used by the main model file; all that is needed is to name the
configuration file correctly.

Exporting the model

Depending on how you set up the animations for your model, you will either
export the model and animations as one DTS file, or you will export the model
as a DTS file and each animation as a separate DSQ file.

-Exporting all as one DTS file

To export the model as one DTS file, the model and all animation data must
be present in a single Maya scene file. This section assumes that you have
built and animated your model, and created and configured all the required
sequence nodes for your animations.

Open up the DTS Utility and select Export...
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{1, DTS Utility %]
DTS Setup Help

Export Control

Export...
Export Shape

Export Sequence

Export Settings...

Sequence Nodes

Sequence Attributes

Create Sequence Hode

Scene Nodes

Erbed Shape

Renumber Selection. ..

Reqgizter Details

Bounding Box

Create Bounding Box

v Lock

[ Hide

In the dialog box that appears, select a name for your model file and make
sure that Files of type is set to exportDTS

Export {... and Settings\Amr Bekhit\My Documents\mayal\projects)

|E:'\Documents and Settingshamr Bekhit\by Documentshmnay abprojects
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Documents
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() Torque Objects
@Torque Test
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[*4 helmut, bmp
ggdump .dmp
bozman_anim,dts
i boxman, mb

@ﬂboxman_anim mb
i boxman_root.mb
@ﬂhelmutz. b

i helmut model, mb

@ﬂHelmut. mb
@_ﬂHeImut_rooQ b
MHelmut_root.mh
i Helmut_run.mb
@ﬂhelmut_sword_slash. mb
@ﬂhelmut_workjng .mb
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i shietd. mb
Msword.mh
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Mtester.mh
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r_‘_’, helmut, cfg

r_‘_’, rifle. cFg
blockman, mtl
T-Beamn Cannon,mtl
%] T-Beam Cannon.obj
2 Rifle bga

|:] Hoplite's Helmet. png
E] Rifle.png

Igj OpeniayaErrorLog, bxt
EHoplite's Helmet rar

File name:

| bioxman

j Export |

Files of tppe:

| expantDTS (77

ks

Set Praject... | Optiohs...

ﬂ Cancel

You should see the model playing through its animations and then the export

will be completed.

The model can now be viewed in the Show Tool or used in Torque.

22



Exporting skinned models and animations from Maya to Torque
By Amr Bekhit

-Exporting model and animation as separate DSQ files

First open up the main model file. This file should contain the model and
skeleton and no sequence nodes. Export the model in the same manner as
above.

Next open up one of the animation scene files. This file should contain the
model and one sequence node. Open the DTS Utility and select DTS—>
Export Settings...

]

it DTS Utility
DTS

Setup  Help

Export...

Export Shape

Export Sequence

Export Shape and Dump

Export Sequence and Dump [
Export Setkings... |

Erahod Chana t

In the dialog that appears, modify the Sequence Name and Sequence
Location text boxes to determine where you want to save your DSQ file, then
click on Close

il Export Settings @
Edit

Shape Mame |bonan_wave.dts
Shape Location |E:\Documents anid SetingsiAmr Bekhitsby Doct Browse. . |
Sequence Mame |boxman_wave.dsq

Sequence Location |lings\.-’-\mr Bekhit'My Documentshmapatprojectsh. Browse... |

[ Use Global Settings

Reset to Default I Close

v

Finally, in the DTS Ultility, select Export Sequence
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!, DTS Utility Ed
DTS Setup  Help
Export Control
T —
Esport Shape

Export Sequence ‘\‘5

Export Settings...

Sequence Nodes
Sequence Attributes

Create Sequence Mode

Scene Modes
Embed Shape

Renumber S election...

Register Details

Bounding Box

Create Bounding Bax |

v Lock [ Hide

You should see the model playing through its animation and then the DSQ
export will be completed.

Repeat the above steps for each animation you need to export.

About the guide

This guide was written due to the lack of detailed information in one place on
this subject. | hope that you have found the guide useful, and if there are any
queries or suggestions please feel free to contact me by email:

amrbekhit [at] gmail [dot] com.

--Amr Bekhit
12 September 2006
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